GrailsFlow

AndJoin acts like OrJoin

Details

  • Type: Bug Bug
  • Status: Closed Closed
  • Priority: Blocker Blocker
  • Resolution: Fixed
  • Affects Version/s: 1.0
  • Fix Version/s: 1.0.12
  • Component/s: None
  • Labels:
    None
  • Environment:
    Plugin Version is grailsflow-core-1.0-rc8, reproducible in grailsflow-core-1.0.6
  • Request Controller:
    Albers, Stephan
  • External Supervisor:
    Please select
  • Executing Programmer:
    Please select
  • Ext Project Id:
    JCGFW-01

Description

When using a "fork" (with two threads) and an "AndJoin" to merge the two threads, the "AndJoin" acts like an "OrJoin", i.e. when the first thread is finished, the AndJoin fires the next event without waiting for the second thread.

See attached process definition as an example.

Activity

Voitovich, Maria added a comment - 15/Oct/10 1:14 PM

Cannot reproduce in 1.0 branch (grailsflow-core-1.0.7-SNAPSHOT)
Fixed in 1.0-rc branch (grailsflow-core-1.0-rc10-SNAPSHOT)


People

Vote (0)
Watch (0)

Dates

  • Created:
    15/Oct/10 9:14 AM
    Updated:
    07/Feb/12 1:23 PM
    Resolved:
    07/Feb/12 1:23 PM